tscのバージョンがおかしい

APIを作ったので次はフロントだ!と思い、
せっせとTypeScriptを覚えようと思ったところで躓きました。

tsc --initを実行してもinitが無いと言われる。
おんやぁ?と思い、tsc -vを実行してみると、
Version: 1.0.3.0となっているでは無いですか。
npm -g list --depth=0でパッケージのバージョンを確認。
typescript@2.5.2
バージョンが合ってないですね。

何のバージョンだったか

VisualStudioのSDKに入っているTypeScriptを参照していました。
環境変数のPathからその部分を消したらきちんとtscのバージョンも2.5.2に。

こういう罠やめて欲しいですね。
まあ解決したので、バリバリTypeScriptを書いていこうと思います。

コメントを残す

メールアドレスが公開されることはありません。